开发的IDE是吃饭的家伙,新版的更新可能会提高你的编程效率,所以升级了最新版的phpstorm。

假如对phpstorm不了解的可以看下

官网

具体的错误:

原本的代码中使用到的 json_encode 函数出现黄线,这是逼死强迫症的节奏

TIM截图20181129112648

查看详细错误说缺少引入 ext-json 

处理方式有2中:

第一种就是直接处理掉phpstorm在新版本中检测composer.json文件的设置

TIM截图20181129112856

第二种方法是:

在composer.json文件中加入依赖

TIM截图20181129112717

就可以处理掉这个黄线的,emm。

引用 :https://www.douban.com/note/694980272/